Back to overview
Downtime
Trading service degradation
Feb 18, 2026 at 07:25am UTC
Affected services
Frontend API
API
Resolved
Feb 18, 2026 at 07:50am UTC
The issue is fixed.
Affected services
Updated
Feb 18, 2026 at 07:35am UTC
We are working on a fix.
Affected services
Updated
Feb 18, 2026 at 07:32am UTC
We experienced full outage of trading service.
Affected services
Created
Feb 18, 2026 at 07:25am UTC
We experienced trading portal degradation due to too many requests.
Affected services